Ad Radar
 //   //   //   //   //  
bad idle in my 99 vw cabrio gl manual 5speed transmission

bad idle in my 99 vw cabrio gl manual 5speed transmission

  
european car
Item Posts    Sort Order

bad idle in my 99 vw cabrio gl manual 5speed transmission

 
ttcleo2 ttcleo2
New User | Posts: 1 | Joined: 07/14
Posted: 07/06/14
12:56 PM

my car idle is not correct it goes a little above and below 1rpm it shakes and has misfired a couple times. I changed the plugs yesterday but the old ones looked fairly new but they were ngk plugs I replaced them with ngk forgetting that bosch is recommended. ive had this car about six months now but this just started like a little over a week ago so I don't think its from having ngk plugs because it ran good never had this problem when I bought it until recently. what else could make this happen besides the wires. could it just possibly need new wires? my engine light came on I took it to advance they said I needed a throttle position sensor an told me I could just replace that by getting a new one and removing my gas pedal an plug the new harness in and replace the new pedal. I know that you cannot do that you have to replace the whole throttle body, so I didn't like their advice so I called the garage that changed my water pump, timing belt, and my serpentine belt he said if the light came on again bring it up for him to plug it into his computer and if it stayed off it was just a bad reading because advance auto and those places have not so good code readers sure enough the light came on he said only thing that showed up was my fuel temp but that was nothing to worry about that it probably just simply needs a tune up. I did the plugs yesterday as I said and it is still running the same way. it seems that after I drive for a while the idle is normal at some points but then starts to idle bad again in the same drive to my destinations. while driving it seems ok but when in fifth gear it jerks me a little as if the gear was to high for the speed but I can be going fifty mph in fifth gear and it jerks like that when I let off the gas and push the gas pedal down. I try to do most of the repairs myself because I am a single mother of two young children and labor is just simply to expensive for me to pay. any suggestions?